Posted Tue, 07 Mar 2017 17:21:56 GMT by Alan Glazier

Hi Support,

 

Thanks for your patience.  I checked all the services,pools and dcom again, and now I am getting the tool bar in desk.  Yeah!

 

However when I go to login, I am receiving "Failed to register on Login".   I have tried checking and unchecking hotseating as I believe we use that feature.  But that didn't change anything.

 

My CMService service does not seem to stay running.  I am not sure if that is by design or not. 

I am seeing the following application error in the event logs:

Log Name: Application
Source: ASP.NET 4.0.30319.0
Date: 3/7/2017 9:08:11 AM
Event ID: 1310
Task Category: Web Event
Level: Warning
Keywords: Classic
User: N/A
Computer: aries.birkusa.birkenstockusa.com
Description:
Event code: 3008 Event message: A configuration error has occurred. Event time: 3/7/2017 9:08:11 AM Event time (UTC): 3/7/2017 5:08:11 PM Event ID: dabed324d13a41db8db7802e90e406b3 Event sequence: 1 Event occurrence: 1 Event detail code: 0 Application information: Application domain: /LM/W3SVC/1/ROOT/AMCDotNetEventAdapterWebService-197-131333800910254222 Trust level: Full Application Virtual Path: /AMCDotNetEventAdapterWebService Application Path: C:\Program Files (x86)\AMC Technology\Dot Net Application Adapter\AMCDotNetEventAdapterWebService\ Machine name: ARIES Process information: Process ID: 17328 Process name: w3wp.exe Account name: ARIES\ccs_service Exception information: Exception type: ConfigurationErrorsException Exception message: Could not load file or assembly 'CMGatewayFactory' or one of its dependencies. An attempt was made to load a program with an incorrect format.
at System.Web.Configuration.CompilationSection.LoadAssemblyHelper(String assemblyName, Boolean starDirective)
at System.Web.Configuration.CompilationSection.LoadAllAssembliesFromAppDomainBinDirectory()
at System.Web.Configuration.AssemblyInfo.get_AssemblyInternal()
at System.Web.Compilation.BuildManager.GetReferencedAssemblies(CompilationSection compConfig)
at System.Web.Compilation.BuildManager.CallPreStartInitMethods(String preStartInitListPath, Boolean& isRefAssemblyLoaded)
at System.Web.Compilation.BuildManager.ExecutePreAppStart()
at System.Web.Hosting.HostingEnvironment.Initialize(ApplicationManager appManager, IApplicationHost appHost, IConfigMapPathFactory configMapPathFactory, HostingEnvironmentParameters hostingParameters, PolicyLevel policyLevel, Exception appDomainCreationException)

Could not load file or assembly 'CMGatewayFactory' or one of its dependencies. An attempt was made to load a program with an incorrect format.
at System.Reflection.RuntimeAssembly._nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, RuntimeAssembly locationHint, StackCrawlMark& stackMark, IntPtr pPrivHostBinder, Boolean throwOnFileNotFound, Boolean forIntrospection, Boolean suppressSecurityChecks)
at System.Reflection.RuntimeAssembly.InternalLoadAssemblyName(AssemblyName assemblyRef, Evidence assemblySecurity, RuntimeAssembly reqAssembly, StackCrawlMark& stackMark, IntPtr pPrivHostBinder, Boolean throwOnFileNotFound, Boolean forIntrospection, Boolean suppressSecurityChecks)
at System.Reflection.RuntimeAssembly.InternalLoad(String assemblyString, Evidence assemblySecurity, StackCrawlMark& stackMark, IntPtr pPrivHostBinder, Boolean forIntrospection)
at System.Reflection.RuntimeAssembly.InternalLoad(String assemblyString, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection)
at System.Reflection.Assembly.Load(String assemblyString)
at System.Web.Configuration.CompilationSection.LoadAssemblyHelper(String assemblyName, Boolean starDirective)

Request information: Request URL: https://aries.birkusa.birkenstockusa.com:443/AMCDotNetEventAdapterWebService/AMCEventService.asmx Request path: /AMCDotNetEventAdapterWebService/AMCEventService.asmx User host address: 172.16.9.8 User: Is authenticated: False Authentication Type: Thread account name: ARIES\ccs_service Thread information: Thread ID: 42 Thread account name: ARIES\ccs_service Is impersonating: False Stack trace: at System.Web.Configuration.CompilationSection.LoadAssemblyHelper(String assemblyName, Boolean starDirective)
at System.Web.Configuration.CompilationSection.LoadAllAssembliesFromAppDomainBinDirectory()
at System.Web.Configuration.AssemblyInfo.get_AssemblyInternal()
at System.Web.Compilation.BuildManager.GetReferencedAssemblies(CompilationSection compConfig)
at System.Web.Compilation.BuildManager.CallPreStartInitMethods(String preStartInitListPath, Boolean& isRefAssemblyLoaded)
at System.Web.Compilation.BuildManager.ExecutePreAppStart()
at System.Web.Hosting.HostingEnvironment.Initialize(ApplicationManager appManager, IApplicationHost appHost, IConfigMapPathFactory configMapPathFactory, HostingEnvironmentParameters hostingParameters, PolicyLevel policyLevel, Exception appDomainCreationException)
Custom event details:
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<System>
<Provider Name="ASP.NET 4.0.30319.0" />
<EventID Qualifiers="32768">1310</EventID>
<Level>3</Level>
<Task>3</Task>
<Keywords>0x80000000000000</Keywords>
<TimeCreated SystemTime="2017-03-07T17:08:11.000000000Z" />
<EventRecordID>2898</EventRecordID>
<Channel>Application</Channel>
<Computer>aries.birkusa.birkenstockusa.com</Computer>
<Security />
</System>
<EventData>
<Data>3008</Data>
<Data>A configuration error has occurred.</Data>
<Data>3/7/2017 9:08:11 AM</Data>
<Data>3/7/2017 5:08:11 PM</Data>
<Data>dabed324d13a41db8db7802e90e406b3</Data>
<Data>1</Data>
<Data>1</Data>
<Data>0</Data>
<Data>/LM/W3SVC/1/ROOT/AMCDotNetEventAdapterWebService-197-131333800910254222</Data>
<Data>Full</Data>
<Data>/AMCDotNetEventAdapterWebService</Data>
<Data>C:\Program Files (x86)\AMC Technology\Dot Net Application Adapter\AMCDotNetEventAdapterWebService\</Data>
<Data>ARIES</Data>
<Data>
</Data>
<Data>17328</Data>
<Data>w3wp.exe</Data>
<Data>ARIES\ccs_service</Data>
<Data>ConfigurationErrorsException</Data>
<Data>Could not load file or assembly 'CMGatewayFactory' or one of its dependencies. An attempt was made to load a program with an incorrect format.
at System.Web.Configuration.CompilationSection.LoadAssemblyHelper(String assemblyName, Boolean starDirective)
at System.Web.Configuration.CompilationSection.LoadAllAssembliesFromAppDomainBinDirectory()
at System.Web.Configuration.AssemblyInfo.get_AssemblyInternal()
at System.Web.Compilation.BuildManager.GetReferencedAssemblies(CompilationSection compConfig)
at System.Web.Compilation.BuildManager.CallPreStartInitMethods(String preStartInitListPath, Boolean&amp; isRefAssemblyLoaded)
at System.Web.Compilation.BuildManager.ExecutePreAppStart()
at System.Web.Hosting.HostingEnvironment.Initialize(ApplicationManager appManager, IApplicationHost appHost, IConfigMapPathFactory configMapPathFactory, HostingEnvironmentParameters hostingParameters, PolicyLevel policyLevel, Exception appDomainCreationException)

Could not load file or assembly 'CMGatewayFactory' or one of its dependencies. An attempt was made to load a program with an incorrect format.
at System.Reflection.RuntimeAssembly._nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, RuntimeAssembly locationHint, StackCrawlMark&amp; stackMark, IntPtr pPrivHostBinder, Boolean throwOnFileNotFound, Boolean forIntrospection, Boolean suppressSecurityChecks)
at System.Reflection.RuntimeAssembly.InternalLoadAssemblyName(AssemblyName assemblyRef, Evidence assemblySecurity, RuntimeAssembly reqAssembly, StackCrawlMark&amp; stackMark, IntPtr pPrivHostBinder, Boolean throwOnFileNotFound, Boolean forIntrospection, Boolean suppressSecurityChecks)
at System.Reflection.RuntimeAssembly.InternalLoad(String assemblyString, Evidence assemblySecurity, StackCrawlMark&amp; stackMark, IntPtr pPrivHostBinder, Boolean forIntrospection)
at System.Reflection.RuntimeAssembly.InternalLoad(String assemblyString, Evidence assemblySecurity, StackCrawlMark&amp; stackMark, Boolean forIntrospection)
at System.Reflection.Assembly.Load(String assemblyString)
at System.Web.Configuration.CompilationSection.LoadAssemblyHelper(String assemblyName, Boolean starDirective)

</Data>
<Data>https://aries.birkusa.birkenstockusa.com:443/AMCDotNetEventAdapterWebService/AMCEventService.asmx</Data>
<Data>/AMCDotNetEventAdapterWebService/AMCEventService.asmx</Data>
<Data>172.16.9.8</Data>
<Data>
</Data>
<Data>False</Data>
<Data>
</Data>
<Data>ARIES\ccs_service</Data>
<Data>42</Data>
<Data>ARIES\ccs_service</Data>
<Data>False</Data>
<Data> at System.Web.Configuration.CompilationSection.LoadAssemblyHelper(String assemblyName, Boolean starDirective)
at System.Web.Configuration.CompilationSection.LoadAllAssembliesFromAppDomainBinDirectory()
at System.Web.Configuration.AssemblyInfo.get_AssemblyInternal()
at System.Web.Compilation.BuildManager.GetReferencedAssemblies(CompilationSection compConfig)
at System.Web.Compilation.BuildManager.CallPreStartInitMethods(String preStartInitListPath, Boolean&amp; isRefAssemblyLoaded)
at System.Web.Compilation.BuildManager.ExecutePreAppStart()
at System.Web.Hosting.HostingEnvironment.Initialize(ApplicationManager appManager, IApplicationHost appHost, IConfigMapPathFactory configMapPathFactory, HostingEnvironmentParameters hostingParameters, PolicyLevel policyLevel, Exception appDomainCreationException)
</Data>
</EventData>
</Event>

Please let me know how to proceed.

Thanks,

Alan

Posted Tue, 07 Mar 2017 20:58:13 GMT by Alan Glazier

I should have added, I am trying to use your own authentication.  Not windows domain.

Posted Tue, 07 Mar 2017 21:53:11 GMT by

Alan, can you please show the "Managed Pipeline Mode" and how "Enable 32bit applications' are set for both the .Net 4.5 and 4.5 Classic?

Also, since you are not using the domain login, usuing manual login you will want to open IIS Manager, then expand "Sites", expand "Default Web Site", select "Webtoolbar" and click on the "Application Settings" icon.

Inside of the application Settings window, you will see the 4th from the top reading "AuthServiceSequence" reading "WindowsIntegrated,Unified". Double click on that and remove the windowsIntegrated as well as the comma so that the line only reads 

Unified

Next, double click on "UnifiedAuthServiceSequenceOverride", the fourth one from the bottom and it will read "WindowsIntegrated,Unified".  Remove the WindowsIntegrated as well as the comma so that the line only reads

Unified

Like you did previously, then you can reset IIS but please let me know the configuration of .Net v4.5 and .NET v4.5 Classic as well.

Posted Wed, 08 Mar 2017 20:13:13 GMT by

Hello Alan,

So what you need to do in this circumstance is set the following settings in under Application Pools

DesktoolbarAppPool

.NET CLR Version: v4.0

Enable 32-Bit Application: True

ManagedPipeline Mode: Integrated

Queue Length: 5000

AMCDotNetAdapter

.NET CLR Version: v2.0

Enable 32-Bit Application: True

ManagedPipeline Mode: Classic

Queue Length: 5000

AMCAdminWebPool

.NET CLR Version: v2.0

Enable 32-Bit Application: True

ManagedPipeline Mode: Classic

Queue Length: 5000

The other issue is that you are using a local account as the service account, but then using it as a domain type account, so I do recommend creating a domain user, it does not have to be an admin in the domain, just a user and then assign all of the application pools to this account as well as the DCOM settings.

Lastly, since this is TAPI, you have to make sure under the "CRM Profile" to set under the "Login" section "Ignore Login" to TRUE.

After this, then resetting services as well as IISRESET everything will work and you can test away and show off the integration and the work you have done with it.

You must be signed in to post in this forum.