Posted Tue, 28 Mar 2017 18:41:04 GMT by Alan Glazier Birkenstock, USA IT Director


We had been running fine for a few weeks.  My network admin installed the Backup Exec agent on our server and rebooted.  Now I cannot get the CTI function to work or get into the admin screen. 


I looked at all the login prompts and they seem okay.  I am obviously missing something somewhere.


In the application pools the "AdminToolAppPool" is stopped and it won't start (it starts and then stops).   


When I try to browse to any of the sites, I am getting a certificate warning, but I see my certificate is installed and not expired.


I am seeing this error in the event logs: "Application pool DesktoolbarAppPool has been disabled. Windows Process Activation Service (WAS) encountered a failure when it started a worker process to serve the application pool."


The admin console displays this message when I try to browse to it. 

Service Unavailable

HTTP Error 503. The service is unavailable.


Posted Tue, 28 Mar 2017 18:45:07 GMT by

Hello Alan,

Have you recently changed the password to the service account user?

Can you verify that the services are running within the application pool?  If there are certain services stopped, try starting them, then use this to access the portal from the Contact Canvas Server.


After attempting to access that site, do services stop in the application pools?

Posted Tue, 28 Mar 2017 18:52:16 GMT by Alan Glazier Birkenstock, USA IT Director

Hi Iggy,


The account is still active and the password still works.


The AdminToolAppPool will not remain started.  I retyped in the credentials for that pool.  It seems to start until I browse to the AdministrationTool, then it stops.





Posted Tue, 28 Mar 2017 18:57:28 GMT by

Usually that means that one of the credentials have changed.  As I remember, this was a local account, that is also a domain account, can you verify the credentials, maybe the account is locked within AD. 

Also, can you right click on the start button, then click "Computer Management", expand "Services and Applications", select "Services" and see what state under services "CMService" is at.  Is it running, stopping or restarting? 

If it is stopped, right click on it and select restart.  Did it stop immediately? 

Posted Tue, 28 Mar 2017 19:18:25 GMT by Alan Glazier Birkenstock, USA IT Director

We changed all the accounts to use a domain account (amc_service) when you helped me last.  I know the account works because I logged on to the computer using those credentials interactively.


CMService starts, then immediately stops.  I get a message saying "The CMService service on Local Computer started and then stopped....."



Posted Tue, 28 Mar 2017 20:00:49 GMT by

Can you attempt, to log out of the machine then log back in?

Posted Tue, 28 Mar 2017 21:01:15 GMT by Alan Glazier Birkenstock, USA IT Director

Tried that.  Still doesn't allow me into the Administration Tool.


I am not sure if this has anything to do with it.

I am seeing this error in the Application Logs.  The Open Procedure for service "aspnet_state" in DLL "C:\Windows\System32\aspnet_counters.dll" failed. Performance data for this service will not be available. The first four bytes (DWORD) of the Data section contains the error code.


And I am seeing this in the System Logs:

DCOM got error "1385" and was unable to logon birkusa\amc_service in order to run the server:



Posted Thu, 30 Mar 2017 18:52:54 GMT by

Hello Alan,

So it seems the issue you were encountering was one due to the fact that your initial install was under one user, then after the quick uninstall and reinstall, everything worked fine.  Thankfully, we easily backed up your agent database, and after the reinstall putting it back and resetting IIS allowed the entire integration to work, but also allowed you to restore you entire configuration without the need of reconfiguration.


Please do let us know if you are having any other issues.

Thank you.

You must be signed in to post in this forum.